Данный сайт является проектом ООО "Амакс". Сегодня: Вторник, 06.12.2016, 20:58

Приветствую Вас Гость

Loading
[ Новые сообщения · Участники · Правила форума · RSS · ?
Loading
Страница 1 из 11
Неофициальный форум технической поддержки Hikvision » Оборудование и программное обеспечение Hikvision » IP (сетевые) камеры Hikvision (в том числе IP PTZ) » РЕШЕНО: Просмотр камер DS-2CD862MF в инете через IE (Ошибка пароля)
РЕШЕНО: Просмотр камер DS-2CD862MF в инете через IE
shikДата: Среда, 22.06.2011, 14:38 | Сообщение # 1
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Что имеем: роутер DIR-615 к которому подключен интернет со статическим адресом, 3 камеры DS-2CD862MF и видеосервер на базе ПК с установленным ПО Трассир. После проброса портов для трассира, видеосервер работает нормально, можно через IE или клиентскую часть трассира посмотреть видеоданные с камер, заодно ведется круглосуточная запись на этот видеосервер. Теперь задача стоит по обеспечению получения видеоданных напрямую с каждой камеры в эксплоере. При пробросе портов на маршртизаторе, не возможно получить данные ни с одной из камер из интернета, внутри локалки все нормально, но в какой-то момент все-таки это удалось сделать получив окно авторизации для входа на видеокамеру через эксплорер, после ввода пороля админа появляется надпись Login failed, пароль не менялся логин тоже.
Вопросы: 1. Судя по всему, более чем одному пользователю к камере подключиться не возможно?
2. Как решить проблему с авторизацией "Login failed"?
3. Основная задача всей системы - запись изображения с камер, и доступ через интернетэксплорер к каждой камере отдельно одновременно нескольким пользователям, с записью проблем нет, а вот с доступом не понятно. прошу вашей помощи.
Заранее прошу прощения если где-то не вполне ясно выразился. готов исправиться smile
PS создаетя впечатление что веб сервер камеры как-то неустойчиво (глючно) работает, хотя с изображение проблем нет (тьфу 3 раза), прошивка может неудачная?


Сообщение отредактировал shik - Среда, 22.06.2011, 14:43
 
AlexandrДата: Четверг, 23.06.2011, 18:57 | Сообщение # 2
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
распишите как организован проброс портов. по идее должно быть так - адреса и порты камер 192.168.0.10 80 8000 первая, 192.168.0.11 80 8000 вторая, 192.168.0.12 80 8000 третья. проброс на первую вход 80 и 8000 на 192.168.0.10 80 8000, вторую 81 и 8001 на 192.168.0.11 80 8000, третью 82 и 8002 на 192.168.0.12 80 8000. или второй вариант поменять порты на камерах чтобы разгрузить роут - все порты на камерах +1 - первая 80 8000 внешние 80 8000, вторая 81 8001 внешние 81 8001 и т.д.. позволяет не триггерить порты а пробрасывать напрямую. соответственно в IE подключение - http://адрес:80 или 81 и т.д.
 
shikДата: Пятница, 24.06.2011, 14:21 | Сообщение # 3
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Александр, спасибо! мой косяк был в том, что я не обращал внимание на порт 8000, а работал с портом 8Х. Теперь с авторизацией все нормально, но появилась следующая проблема: нет изображения ""время" Channel 1 preview failed" заходил под админом. А так же заметил, что через некоторое время порт 8Х (принадлежащий камере) оказался закрытым sad хотя буквально несколько минут назад был открыт!!! Косяк камеры или роутера? хотя специально для видеосервера трассир в роутере открыты соответствующие порты и такого, чтоб они сами закрывались я не наблюдал, а тут прям мистика какая-то cry получается, что ПО камеры перестает обращаться по этому порту, и соответственно порт оказывается закрытым, такое возможно? Кстати проброс портов организован по второму варианту :
Quote (Alexandr)
второй вариант поменять порты на камерах чтобы разгрузить роут - все порты на камерах +1 - первая 80 8000 внешние 80 8000, вторая 81 8001 внешние 81 8001 и т.д..

Надо бы шамана вызвать smile а то уже wacko
 
AlexandrДата: Понедельник, 27.06.2011, 10:58 | Сообщение # 4
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
Quote
""время" Channel 1 preview failed"

это сообщение при работе через IE и интернет ? варианты: долгий пинг, маленькая скорость, не доступен порт видео (8000).
закрытый порт чем проверялся ? порт закрыт на камере или роутере ? если в локалке всё нормально, то похоже на косяк роутера.

Доступно только для пользователей проверьте прошивку камеры.
 
shikДата: Понедельник, 27.06.2011, 14:12 | Сообщение # 5
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Quote (Alexandr)
это сообщение при работе через IE и интернет ?
Именно так.
Quote (Alexandr)
долгий пинг
2-3 мс можно сказать почти как в локалке;
Quote (Alexandr)
маленькая скорость
на стороне отдачи 2 мб, прием 4 мб, считаю достаточно;
Quote (Alexandr)
закрытый порт чем проверялся ?
сервисов в интернете море, я выбрал пару, проверял открыты ли те порты которые нужны для работы трассира через IE-все открыто в соответствии с условиями указанными в роутере (проверял через интернет), а те, что прописаны для камер 81,82,83 - закрыты при попытки зайти из интернета.
Quote (Alexandr)
порт закрыт на камере или роутере ? если в локалке всё нормально, то похоже на косяк роутера
в локалке все нормально, получается, что порт закрыт именно на роутере потому, что закрыт на камере ()простите за каламбур), я к сожалению до этого плотно не занимался настройками и пробросом портов, как- то все само по себе получалось, где инструкция помогала, где опыт. Смущает, то что в локалке все работает при прописке в IE адреса вида 192.168.0.1:81 попадаем на нужную камеру и без проблем работаем с ней, а вот через интернет - нет, (прописываем конечно по другому: ип статический адрес выданный провайдером:81).
Quote (Alexandr)
проверьте прошивку камеры
посмотрел какая стоит у меня: V2.0 build100329 V4.0 build090606, я так понимаю у меня еще новее чем Вы мне рекомендовали (или просто у меня еще не обкатанная smile ) по этому такие глюки.
Заметил несколько особенностей: 1. во вкладке конфигурации каналов меняя любые настройки (битрейт, качество, поток) после ребута и логаута, повторно зайдя на камеру все настройки возвращаются к максимальным (по умолчанию); 2. Не удается создать нового пользователя "сохраненные параметры ошибочны" (Save parameters failed! ) sad
может откатить прошивку?, с той прошивкой что Вы мне рекомендовали наблюдались подобные глюки как у моей?

PS. Поправьте меня если я ошибаюсь: порты открываются на роутере для определенного устройства с IP-адресом,
это устройство (точнее его ПО) постоянно "прослушивет" данный порт (может какой-нибудь гость "постучится"?), по этому если
посмотреть на это "дело" из интернета ("постучаться" на порт), то получим ответ, что порт открыт (типа "заходи"). В моем случае
после задания портов на камере, прописки (открытия) портов на роутере, в течении минут 5-10 можно достучаться до камеры из инета,
получить окно авторизации камеры (тока видеопотока получить не удалось - Channel 1 preview failed), и усё, через указанное врямя порт
оказывается закрыт (ПО устройства "устало" слушать (ушко заболело smile )), выходит косяк прошивки камеры, жду Вашего резюме.


Сообщение отредактировал shik - Понедельник, 27.06.2011, 14:57
 
AlexandrДата: Понедельник, 27.06.2011, 14:49 | Сообщение # 6
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
Quote
81,82,83 - закрыты при попытки зайти из интернета.

а правила проброса меняли при проверке ? ведь проверяли с компа и часто сервисы используют надстройки IE для проверок.
ещё вариант - зхакрыты порты на стороне оборудования провайдера. попробуйте на wan интерфейс роутера поставить комп, перенастроить роутер и проверить с него доступность камер.

насчёт самого 615 и проброса портов на нём -
Проброс порта на D-Link Dir 615
юзаем поисковики )
можно попробовать альтернативную прошивку (dd-wrt, Олега (wl500g.info) и т.д.)

насчёт прошивки камеры - запрос на обновление отослал, в младшем билде таких ошибок нет.
 
shikДата: Понедельник, 27.06.2011, 15:02 | Сообщение # 7
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Quote (Alexandr)
Проброс порта на D-Link Dir 615
юзаем поисковики )


спасибо, это уже читал, на всякий случай попробую еще раз повнимательней прочитать.

PS Поправьте меня если я ошибаюсь: порты открываются на роутере для определенного устройства с IP-адресом,
это устройство (точнее его ПО) постоянно "прослушивет" данный порт (может какой-нибудь гость "постучится"?), по этому если
посмотреть на это "дело" из интернета ("постучаться" на порт), то получим ответ, что порт открыт (типа "заходи"). В моем случае
после задания портов на камере, прописки (открытия) портов на роутере, в течении минут 5-10 можно достучаться до камеры из инета,
получить окно авторизации камеры (тока видеопотока получить не удалось - Channel 1 preview failed), и усё, через указанное врямя порт
оказывается закрыт (ПО устройства "устало" слушать (ушко заболело)), выходит косяк прошивки камеры, жду Вашего резюме.
 
AlexandrДата: Понедельник, 27.06.2011, 15:48 | Сообщение # 8
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
так ведь
Quote (shik)
Смущает, то что в локалке все работает при прописке в IE адреса вида 192.168.0.1:81 попадаем на нужную камеру и без проблем работаем с ней, а вот через интернет - нет, (прописываем конечно по другому: ип статический адрес выданный провайдером:81)

собственно
Quote (shik)
(ПО устройства "устало" слушать (ушко заболело))
болело бы и в локалке. разве нет ?
насчёт портов всё верно - открытый порт ждёт соединения. но вот доступность из инета портов (проверить провайдера и проброс портов на своём роутере) через комп нужно было создавая для каждого порта правило проброса на комп с поднятым сервером ( или клиентом) с открытыми портами 80 и 8000. т.е. проверяем последовательно узлы и исключаем из обработки уже работающие связки. в локалке всё ок - роутер. комп на внешнем порту роутера или сервисы по тестированию портов (2ip.ru к примеру) всё ок - провайдер и нюансы построения его сети.
 
shikДата: Вторник, 28.06.2011, 09:44 | Сообщение # 9
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Спасибо, буду экспериментировать дальше, судя по всему проблема в связке роутер-камеры, звонил провайдеру, по топологии его сети, заверили, что ни фаерволов ни каких других ограничений на их стороне нет, и схема построения камеры-роутер-интернет 100% должна работать (у них у самих в качестве рекламы на сайте есть 2 камеры ип, смотрят на центральные улицы города). Как обычно кивают на D-link, говорят косячный, но другого нет, хотелось бы для ясности узнать по поводу прошивки камеры, наверное попробую перепрошить на рекомендованную Вами, а там ясно будет cry
 
AlexandrДата: Вторник, 28.06.2011, 14:46 | Сообщение # 10
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
DIR-620 ведёт себя похоже - одну камеру пробрасывает нормально, а 2,3,4 уже не пробрасывает. Dir-320 с DD-WRT совершенно спокойно 4ре камеры пробрасывает. на родной тоже косяки, правда проброс не пробовал на родной. нужен был мост wi-fi и потому DD-WRT выбрали.
пс - буду признателен за ответ по факту что да как получилось. очень может пригодится в копилочке знаний )
 
shikДата: Среда, 29.06.2011, 11:02 | Сообщение # 11
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Quote (Alexandr)
буду признателен за ответ по факту что да как получилось. очень может пригодится в копилочке знаний )

обязательно отпишусь, просто сейчас параллельно несколько проектов идут, не всегда есть время заниматься только чем-нибудь одним, по этому может пройти какое то время smile
 
AlexandrДата: Среда, 29.06.2011, 18:07 | Сообщение # 12
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
получил Доступно только для пользователей и проверил - всё сохраняется корректно. к сожалению подробного описания изменений в прошивке нет (
пс - на V2.0 build 090629 V4.0 build 090606 тоже всё сохранялось корректно, видимо в V2.0 build100329 V4.0 build090606 такой баг
 
shikДата: Понедельник, 11.07.2011, 11:31 | Сообщение # 13
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Отлично, значит первым делом прошивку сменю на камерах, Спасибо ОГРОМНОЕ за помощь, о результатах отпишусь!

Добавлено (11.07.2011, 11:31)
---------------------------------------------
Итак, как обещал, отписываюсь, все по порядку:
Понимая, что самому многие проблемы не решить, решено было пригласить "другие мозги" Саша Карпов тебе "респект".
1. Роутер dir-615 Е4 был перепрошит на dd-wrt-чего добились: устойчивая работа, порты для камер всегда открыты (т. е. просто корректная работа роутера), не обошлось без
всякого рода "косячков", но это особенности прошивки dd-wrt и решаются чтением форума с сответствующей темой и "гуглением".
2. Роутер переведен в режим шлюза.
3. после многочисленных эксперементов с прошивками камер выявились такие особенности
-в интерфейсе камеры при одновременной работе с ПО "Трассир" НИ КАКИЕ настройки изменить НЕВОЗМОЖНО, необходимо сначало изменить в "трассире"(разрешение, колличество кадров и др), либо отключить "трассир", произвести изменения (создать пользователя и др), включить "Трассир". Получается так, что "трассир" принудительно все настройки камер ставит "как" у себя.
-Последняя прошивка firmware DS-2CD862MF V2.0 build 100521 V4.0 build 090220 корректная, мона ставить не боясь.
-После эксперементов, а может и не от них, одна из камер ушла в даун и поднять её не удалось, не пингуется, (висить на уровне 9-го этажа и для того чтоб её снять нужна вышка) предположительно
вышел из строя либо БП, либо сетевая в камере.

И теперь то, что "победить" не удалось: одна из камер вошла в какой-то режим- примерно раз в 3 сек. экран заливается белым светом на 1 сек., затем проступает изображение, держится 1-2 сек. и
снова заливается белым светом, повторяется цикл, бесконечно...??? как камеру вывести из этого режима?

PS забыл написать как лечиться вот такая ошибка (один из вариантов) "Channel 1 preview failed".
В моем случае из-за нагрузки на интернет-канал нужно было уменьшить кол-во Кб/сек поставили 256 вместо 2048 и ошибочка пропала


Сообщение отредактировал shik - Понедельник, 11.07.2011, 11:40
 
AlexandrДата: Понедельник, 11.07.2011, 20:19 | Сообщение # 14
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
Quote (shik)
После эксперементов, а может и не от них, одна из камер ушла в даун и поднять её не удалось, не пингуется

поставить SADP и попробовать найти её в сети. там другой механизм опроса устройств в сети в отличии от пинга.
Quote (shik)
одна из камер вошла в какой-то режим- примерно раз в 3 сек. экран заливается белым светом на 1 сек., затем проступает изображение, держится 1-2 сек. и снова заливается белым светом, повторяется цикл, бесконечно...??? как камеру вывести из этого режима?

такого режима есс-но нет в камере ) кроме аппаратных неполадок (в ремонт) в голову приходит засветка камеры и попытка её компенсировать. собственно отсюда вопрос - OSD меню (название камеры, часы и дата) как себя ведут ? тоже заливаются ? да и вообще может ролик куданить скинуть чтоб увидеть своими глазами..
Quote (shik)
"Channel 1 preview failed". В моем случае из-за нагрузки на интернет-канал нужно было уменьшить кол-во Кб/сек поставили 256 вместо 2048 и ошибочка пропала

я об этом ранее и писал )
 
shikДата: Вторник, 12.07.2011, 10:23 | Сообщение # 15
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Quote (Alexandr)
поставить SADP и попробовать найти её в сети. там другой механизм опроса устройств в сети в отличии от пинга.

Именно так и было сделано (отсюда и предположение про БП или сетевушку на камере), про пинг я написал чтоб понятно было, кстати SADP нереально мега классная весчь!!! Советую всем

Quote (Alexandr)
OSD меню (название камеры, часы и дата) как себя ведут ?

OSD меню тоже пропадает и появляется, пропадает и появляется..

Quote (Alexandr)
да и вообще может ролик куданить скинуть чтоб увидеть своими глазами.

готов предоставить, к сожелению нет аккаунта ни на одном из файлообменниках, а в принципе мона и поглядеть через веб, как Вам отправить личное сообщение?

Quote (Alexandr)
я об этом ранее и писал )

Ну, мы ж ленивые smile surprised

отправил Вам личное сообщение, хотелось бы получить Ваше резюме по этой проблеме


Сообщение отредактировал shik - Вторник, 12.07.2011, 10:36
 
AlexandrДата: Вторник, 12.07.2011, 11:15 | Сообщение # 16
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
ответил лс ) возможно и объектив...
 
shikДата: Вторник, 12.07.2011, 14:46 | Сообщение # 17
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Объективы на камерах стоят FUJINON YV10x5HR4A-SA2L 1/3" 1,3 Mp.
После исправления в "свойствах" с Opaque&Flashing на Opaque&Steady при "всполохах" ОСД меню перестало пропадать.
Решил поэксперементировать с менюшкой самой камеры и первый же эксперемент дал результат:
после замены параметра AI на AES во вкладке LENS "всполохи" прекратились. Какие либо изменения с изображением
помимо устранения "всполохов" не замечено cry . Что за параметры? на что влияют? Прошу прощения за свою настойчивость.
Наверное уже достал со своими камерами. smile
 
AlexandrДата: Вторник, 12.07.2011, 16:24 | Сообщение # 18
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
вообщето всё есть в инструкциях ))) собственно включили управление затвором



FUJINON YV10x5HR4A-SA2L
DS-2CD862MF-E, DS-2CD852MF-E, DS-2CD762MF-FB(H), DS-2CD752MF-FB(H), DS-2CD752MF(-E), DS-2CD852F series Network Camera
Прикрепления: 4804084.jpg(31Kb)
 
shikДата: Вторник, 12.07.2011, 16:58 | Сообщение # 19
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
Насколько я понял - AES (автоматический электронный затвор) необходим если в кадре есть постоянно двигающиеся объекты.
В нашем случае конечно все таки правильнее было бы выбрать режим AI (автофокус), так как движущиеся объекты находятся на значительном растоянии, и основная задача камер -передача панарамного изображения.
Но на данный момент я не вижу по изображению существенной разницы между этими двумя режимами.
В таком случае остается только открытым вопрос -сколько проработает объектив (если предположить что в режиме автофокуса он уже не может работать).
Еще раз хочу поблагодарить Вас за содержательные и компетентные ответы на поставленные вопросы, удачи Вам в Вашей карьере, успехов в работе, "респект и уважуха" smile
только сейчас обнаружил: http://www.dssl.ru/support/tech/faq/detail.php?ID=4749, так вот всегда, думаешь, что ты первый с такой проблемой ан нет проблему то уже решили до тебя.


Сообщение отредактировал shik - Вторник, 12.07.2011, 17:21
 
AlexandrДата: Вторник, 12.07.2011, 17:09 | Сообщение # 20
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
AES (Automatic Electronic Shutter) – автоматический электронный затвор
AI (Auto IRIS) – автоматическая регулировка диафрагмы (АРД).
к фокусу отношения не имеет
AF (автофокус) Система, позволяющая объективу камеры автоматически фокусироваться на выбранной части наблюдаемого объекта.

для просвещения в терминах ) -Глоссарий ltv-cctv
 
shikДата: Вторник, 12.07.2011, 17:26 | Сообщение # 21
Группа: Проверенные
Сообщений: 14
Репутация: 0
Статус: Offline
только сейчас обнаружил: http://www.dssl.ru/support/tech/faq/detail.php?ID=4749, так вот всегда, думаешь, что ты первый с такой проблемой ан нет проблему то уже решили до тебя.

Добавлено (12.07.2011, 17:26)
---------------------------------------------

Quote (Alexandr)
Глоссарий ltv-cctv
спасибо, немного не то, что я предположил, но главное, что работает!
 
AlexandrДата: Вторник, 12.07.2011, 18:14 | Сообщение # 22
Группа: Администраторы
Сообщений: 5311
Репутация: 109
Статус: Offline
так потому и попросил показать "живую" картинку ) всёж лучше 1 раз увидеть ...
Quote
возможно и объектив...

))
 
Неофициальный форум технической поддержки Hikvision » Оборудование и программное обеспечение Hikvision » IP (сетевые) камеры Hikvision (в том числе IP PTZ) » РЕШЕНО: Просмотр камер DS-2CD862MF в инете через IE (Ошибка пароля)
Страница 1 из 11
Поиск: