Данный сайт является проектом ООО "Амакс". Сегодня: Четверг, 25.07.2024, 09:53

Приветствую Вас Гость

Поиск по сайтам
[ Новые сообщения · Участники · Правила форума · RSS · ?
Установка оборудования видеонаблюдения в Москве и Московской области
Поиск по форумам
  • Страница 1 из 1
  • 1
Регистратор HiWatch DS-N316D портит файлы. Что делать?
f2065Дата: Вторник, 18.06.2024, 12:32 | Сообщение # 1
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Регистратор HiWatch DS-N316D

На записях часто есть зелёные полоски и квадраты, раз 2-5 минут обязательно вылезает что-то.
Но при живом просмотре видео с камер через регистратор - никаких проблем не бывает.
Т.е. видеопоток с камер в регистратор приходит целым и далее из регистратора в браузер или iVMS для просмотра тоже доходит целым.

А просмотр записи с регистратора - поток явно битый!
Его конечно смотреть можно, но некомфортно - когда каждые несколько минут какие-то зелёные полосы вылезают и потом стоят по минуте (пока картинка в этом месте не обновится естественным образом).

Пропускной способности записи должно хватать (причём с многократным запасом!), стоит 2 диска, тесты дисков все прогнал всё отлично.

Есть идеи?
Регистратор же просто пишет прямой поток, ничего сам не должен перепаковывать?
Но такое чувство что регистратор как-то поток модифицирует и портит при записи...

Настроил SMB-сервер, прописал в камере его. Настроил в камере самостоятельную запись.
Имею запись напрямую с камеры на SMB-сервер, и это же событие записанное регистратором.
Сравниваю видео - в файлах с камеры всё отлично, никаких артефактов, в файлах с регистратора - регулярно фризы картинки, зелёные полосы и прочие артефакты лезут.
И что делать?

Добавлено (18.06.2024, 12:53)
---------------------------------------------
Внимательно изучил моменты сбоя видео. На записи камеры (на SMB-сервере) при покадровом просмотре видно что в этот момент вся картинка делает малозаметное изменение по всему кадру - похоже камера несколько кадров пропустила. Но, для файла камеры это не критично - его все нормально показывают! А вот файл этого же момента с регистратора - выпадение кадра не переносит, с этого момента у него сразу лезут полосы, артефакты, и только через несколько секунд они постепенно уходят.

 
f2065Дата: Суббота, 22.06.2024, 16:22 | Сообщение # 2
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Камеры Hikvision DS-2CD2186G2-ISU(rev.C).
Пробовал поставить microSD в камеру, и получил одновременно записи на microSD и записи в регистраторе.
На регистраторе как обычно артефакты каждые несколько минут, на microSD в эти же моменты - всё отлично (покадрово изучил - вроде даже выпадений кадров нет).

Пробовал отключать часть камер - если оставить 1 камеру - всё нормально!
Если например 4 камеры - уже есть артефакты на записи...

Подключил камеру Hikvision DS-2CD1343G0-IUF(rev.C) взамен 2CD2186G2 (при том что ещё десяток камер в сети работает) - на 2CD1343G0 проблемы нет! Её записи на регистраторе всегда без артефактов.

Пробовал MTU на камерах понизить до 1280. Пробовал битрейт урезать до 8000. Это всё не помогло.

Но вот есть интересная деталь. Я сравнивал настройки потока 2CD1343G0 и 2CD2186G2 - камеры 2CD2186G2 имеют опцию SVC в настройках видеопотока, у камеры 2CD1343G0 такой опции нет.
При этом со стороны регистратора в настройках всех камер такой опции нет - очевидно регистратор не умеет и не поддерживает это.
Отключить опцию SVC в вебинтерфейсе 2CD2186G2 невозможно! Она отключается, можно повторно зайти в настройки убедится что она отключена. Но через 1-2 минуты захожу в настройки - SVC включено!!!
Вероятно регистратор как-то её сам включает на камерах постоянно.

Есть гипотеза что тут именно из-за SVC проблема, судя по описаниям в интернете - SVC в реализации Hikvision как раз и нужно для пропуска некоторых кадров.
Поэтому в прямых потоках с камер - пропущенные кадры есть, но они пропущены корректно (и все плееры это показывают без артефактов), а регистратор при записи неадекватно реагирует на подобные пропуски кадров и пишет какой-то мусор в поток.

Кто-нибудь знает почему у камеры не получается выключить SVC, как его выключить?
 
f2065Дата: Суббота, 22.06.2024, 20:00 | Сообщение # 3
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Проблему очевидно можно разделить на две части (совокупность который является критической):
1. От камер раз в 3-5 минут приходит немного повреждённый/битый/нестандартный поток. Может сами камеры делают так, может какие-то физические проблемы в сети. Не понятно, но само по себе это не критично.
2. Регистраторы HiWatch/Hikvision при записи видеопоток модифицируют и это приводит к большим проблемам если поток был нестандартный. 

В принципе, для решения проблемы - достаточно решить хотя бы одну часть. Но у меня пока нет идей ни по одному пункту.
 
f2065Дата: Суббота, 22.06.2024, 20:40 | Сообщение # 4
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Включил в настройках сети у части камер скорость 10F. В принципе h265+ должно прокачивать на 10мбит без особых потерь.
Это не помогло, по прежнему раз в несколько минут лезут артефакты.
Ну не может же быть одинаковая нестабильность сети что на 100мбит что на 10мбит!
Пинг подтверждает что переключение скорости работает, на 10мбит пинг до камер в несколько раз больше чем на 100мбит.
 
iTuneDVRДата: Суббота, 22.06.2024, 23:33 | Сообщение # 5
Группа: Проверенные
Сообщений: 3931
Репутация: 141
Статус: Offline
Покажи скрины с настройками потоков

Мотивация, направление, посыл ;)
"Вспоминание" паролей Dahua SmartPSS, Hikvision iVMS4200, генерация временного для Uniview. Исследования IT.
www.iTuneDVR.ru
 
Установка оборудования видеонаблюдения в Москве и Московской области
f2065Дата: Воскресенье, 23.06.2024, 00:00 | Сообщение # 6
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Цитата iTuneDVR ()
Покажи скрины с настройками потоков

Да я там всё перепробовал, все комбинации (кроме SVC пока что).
h264/h264+/h265/h265+
переменный/постоянный (кстати для первичного потока по факту постоянный не работает, в любом случае переменный битрейт)
разные битрейты.
двойной VCA вкл/выкл.
Да почти всё везде попереключал. 

Настройки в регистраторе:
  

настройки в камере (сейчас в новой прошивке V5.7.17 build 240606 интерфейс сильно другой стал):
 

Интересная закономерность насчёт артефактов - ни разу не видел их ночью (в монохромном режиме). И ещё их почти не было зимой (когда вокруг всё равномерно белое). В прошлом году проблема была, но осенью и световой день короткий, и потом и снег - в итоге я практически не наблюдал артефактов. А весной, после схода снега - артефакты стали снова постоянно.
Артефакты всегда примерно одинаковые.

На h265 - сначала 1 или 2 вертикальных полосы ближе к центру кадра, потом справа от одной из полос прямоугольник с цветным мусором.

На h264 - в нижней половине кадра вертикальные полосы.

Рандомные сбои в сети должны были бы давать разные случайные артефакты в случайных местах кадра. Но этого никогда не бывает, артефакты всегда имеют похожую логику. Такое чувство что они возникают на каком-то конкретном фрейме потока, которые неправильно интерпретируется регистратором...

Сейчас наконец смог выключить SVC - как оказалось его постоянно регистратор включает (хотя у регистратора нет такой опции). Я в камере создал нового пользователя, без права изменения настроек. И прописал в регистраторе камеру с этим пользователем. Теперь SVC я смог выключить в камере, и обратно он самостоятельно не включается. Завтра днём станет понятно - виноват SVC в этих артефактах или нет...
Прикрепления: 5328136.png (42.6 Kb) · 2561412.png (39.7 Kb) · 8408442.png (21.4 Kb) · 1322711.png (97.1 Kb) · 5163556.png (106.1 Kb) · 6233914.jpg (39.0 Kb) · 8454628.jpg (56.0 Kb)
 
f2065Дата: Воскресенье, 23.06.2024, 09:59 | Сообщение # 7
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Выключение SVC не помогло...

Интересно, а можно как-то обновить компоненты прошивки регистратора? Там же в принципе линукс. Взломать рут, подменить файлы кодеков на аналогичные от более новой модели такой же архитектуры...
Или перепаковать файл прошивки...
 
f2065Дата: Воскресенье, 23.06.2024, 10:16 | Сообщение # 8
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Схема сети:


Регистратор и свитч стоят рядом, вся схема задумана так чтобы регистратор с камерами работали бы автономно от остальной локалки.
Кабель cat5e реально медный, 0.51 сечение. Коннекторы хорошие с 3 зубами (не с 2 как у многих). Пересечений с электропроводкой почти нет, кабель отдельно везде проложен.
Оставлял только 1 свитч и 4 ближайших камеры (они все на доме) - проблема есть.
Менял свитч - проблема есть.
Оставлял только 1 свитч и 1 ближайшую камеру - проблемы нет...
Переключал у камер интерфейсы в 10мбит - не помогло.
Циклический пинг большими пакетами - без проблем.
Если подключить компы вместо камер - сеть заводится на 1000мбит, без ошибок на интерфейсах.
Артефакты по всем камерам 2CD2186G2 лезут, но замена любой камеры 2CD2186G2 на 2CD1343G0 - и с 2CD1343G0 артефактов нет.
Но если оставить 1 камеру 2CD2186G2 - то вроде бы проблема пропадает, т.е. при каких-то условиях 2CD2186G2 работает без артефактов...

Не вижу вот никаких факторов чтобы списать всё на проблемы сети.
Прикрепления: 0045879.png (123.1 Kb)
 
hivsalДата: Воскресенье, 23.06.2024, 13:03 | Сообщение # 9
Группа: Проверенные
Сообщений: 13
Репутация: 2
Статус: Offline
Я может не совсем умную мысль озвучу. Но попробуйте заменить кабели SATA  на регистраторе.
 
f2065Дата: Воскресенье, 23.06.2024, 13:19 | Сообщение # 10
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Цитата hivsal ()
Я может не совсем умную мысль озвучу. Но попробуйте заменить кабели SATA  на регистраторе.

Есть контраргумент для этой идеи:
Выше я упоминал что при параллельной записи на Samba-сервер и в регистратор - в моменты фатальных артефактов на записи регистратора, в записи SMB при покадровом просмотре видны дропы кадров (без артефактов, но дропы есть).
Если бы проблема была на уровне SATA-кабеля или HDD - то артефакты были бы не синхронно с дропами кадров на стороннем SMB (к нему вообще траффик даже не проходит через регистратор - камера сама напрямую пишет в SMB).
 
f2065Дата: Воскресенье, 23.06.2024, 18:45 | Сообщение # 11
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Ещё раз настроил одновременную запись с камеры на SMB и на NVR.
Кстати в этой схеме - общая маршрутизация только на кабеле между камерой и свитчем, далее потоки разделяются.
Дождался артефактов.
У записи регистратора все проблемные моменты времени - на экране лезут артефакты, часы в углу кадра идут.
У записи в SMB - заметно только что часы перескочили сразу на 4 секунды, а артефактов нет.
Т.е. камера в записи на SMB дропнула сразу несколько секунд, а регистратор всё это время писал артефакты (но часы камеры в углу кадра шли).
Всё таки похоже какая-то физическая проблема на уровне сети...

Зашёл в SSH.
У регистратора там совсем урезанный набор команд, ничего толком не посмотреть.
У камер больше линуксовых команд - dmesg, iostat, netstat и т.п., но ничего особо интересно не выявил.
Зато в консоли есть ping.

Однако вот обратил внимание что пинги пакетами по 1300 байт ходят как-то очень нестабильно.
Пинги до камер - до ближних - плавает от 0.6 до 4мсек, до дальних - плавает от 0.6 до 5, иногда до 15мсек...

И чего делать?
Этот тот самый случай когда надо заморачиваться с протяжкой S/FTP кабелей?
Или через POE какие-то помехи приходят?
Попробовать заземлить корпуса свитчей и регистратора?

Поискал какие-то тестеры качества ethernet, но что-то не нашёл. Только детекторы обрыва и прочих явных неисправностей, плюс тестеры прикладного уровня - DHCP/Ping и т.п.
А как оценить уровни искажений сигналов в сети?
 
avalistДата: Понедельник, 24.06.2024, 22:06 | Сообщение # 12
Группа: Проверенные
Сообщений: 1056
Репутация: 84
Статус: Offline
Цитата f2065 ()
Этот тот самый случай когда надо заморачиваться с протяжкой S/FTP кабелей?
нет
Цитата f2065 ()
Или через POE какие-то помехи приходят?
нет
Цитата f2065 ()
Попробовать заземлить корпуса свитчей и регистратора?
нет
Цитата f2065 ()
Пинги до камер - до ближних - плавает от 0.6 до 4мсек, до дальних - плавает от 0.6 до 5, иногда до 15мсек...
камера отвечает на ping, если камера загружена по самое не могу получите задержку на ответ вот и ping может плавать
скрины с настройками битрейта это трэш!!!!! ну вот зачем это все в кучу "кони люди сеть" написано что SVC вкл. при 265 и 264 кодеке у вас включен 265+ вот зачем если не заявлено в даташите, С битретом для 264 выше крыши 8 Мбит/с если точнее, то ставить везде нужно кратно 1024-2048-4096-8192-16384 для 265 очевидно как минимум в 2 раза ниже, не более 4096-6144 иначе смысла в 265 нет вообще для 265+ еще меньше, далее, есть подозрение что вы включили 3 поток ибо разрешение стоит доп потока 1280*720 заявлено 50 Hz: 25 fps (640 × 480, 640 × 360) а вот для третьего как раз 50 Hz: 10 fps (1920 × 1080, 1280 × 720, 640 × 480, 640 × 360) при включении третьего потока там вроде тоже куча ограничений. Ну и не удивлюсь если аналитика включена вся что можно да еще несколько зон детекции smile  все это в общем может давать такой эффект. Ну и про связку камер и DS-N316(D) я промолчу ибо не из того сегмента совсем. И на всякий случай,  N316 может декодировать только 1 камеру в режиме воспроизведения 8Мп.
 
f2065Дата: Понедельник, 24.06.2024, 22:39 | Сообщение # 13
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Цитата avalist ()
камера отвечает на ping, если камера загружена по самое не могу получите задержку на ответ вот и ping может плавать
По mpstat даже в моменты детекта и записи в 2 канала - загрузка процессора камеры не превышает 35%.
Процессор камер имеет большой запас мощности, видимо на случай включения всех видов детекта и многочисленные сложных зон детекта в каждом.

Цитата avalist ()
SVC вкл. при 265 и 264 кодеке у вас включен 265+ вот зачем если не заявлено в даташите,
Не понял мысль, но это всё не важно хотя бы потому что я уже все возможные комбинации перепробовал. Битрейт 5000 и 15fps я пробовал, толку ноль.
На h264 при битрейтах меньше 9 МБит сильно размазываются лица людей, птиц сложно идентифицировать, особенно когда ветер и вся листва качается.
На h265+ на самом деле фактический средний битрейт в районе 3-9мбит, хоть в настройках и указано 11мбит.

Цитата avalist ()
Ну и про связку камер и DS-N316(D) я промолчу ибо не из того сегмента совсем.
Да регистратор нормально камеры тянет. 
А декодирование (для просмотра) нескольких камер сразу - мне не надо. AcuSense средствами регистратора мне тоже не надо, ну а в камерах он спокойно поддерживает это всё.

В данном случае про регистратор в принципе можно вообще забыть, потому что проблема имеет место и при записи на SMB-сервер - а регистратор к этому никакого отношения не имеет.

Но главный контраргумент на тему что я камеры слишком сильно нагрузил - если в сети 2 камеры (причём любые) - то они работают нормально! Проблема становится заметна когда в сети 4 камеры и более. И проблема на всех камерах.
 
f2065Дата: Вторник, 09.07.2024, 15:17 | Сообщение # 14
Группа: Проверенные
Сообщений: 43
Репутация: 0
Статус: Offline
Текущее состояние проблемы артефактов.



Неделю наблюдал за работой после заземления свитчей. Пришёл к выводу что всё же заземление сильно увеличило частоту артефактов. Причём есть какая-то связь со временем суток – ночью мало, днём (кстати в самую жару) артефакты раз в 5-10 минут постоянно, а утром и ближе к вечеру – артефакты вообще лезут каждые 1-2 минуты. По всем камерам с одинаковой частотой, но не единовременно. Убрал заземление свитчей, оставил заземление БП только…

Решил попробовать ферритовые EMI-фильтры. На форумах (особенно зарубежных) спорят о целесообразности их использования на витой паре, но есть аргумент ЗА – некоторые производители POE-телефонов комплектуют их ферритовыми фильтрами. Итак, купил 40 штук 5 мм фильтров на AliExpress, поставил. Внатяг, местами очень не просто было защёлкнуть (надо было видимо 6 мм). Расставил EMI-фильтры везде - на всех UTP со стороны свитча и со стороны камер, по середине длинных линий, на всех проводах DC-питания. Хуже не стало. И даже кажется стало заметно лучше!

Попробовал разные комбинации подключения камер к свитчам, в итоге на главном свитче оставил 4 ближних камеры, камеры с длинными кабелями подключил ко второму свитчу. Вроде бы нашёл комбинацию подключения камер к свитчам где артефакты пореже, раз в час или даже раз в несколько часов (сходу даже не удаётся найти артефакты). В принципе это приемлемо, но хотелось бы понять и решить эту проблему окончательно (чтобы в дальнейшем при реконструкции сети этого избежать). Такое чувство что артефакты пропадают если на каждом свитче не более 2-3 камер (причём даже при каскадном включении PD-свитчей).

Что делать далее – не понятно. Рабочая гипотеза – какие-то перекрёстные помехи в UTP возникают от одновременной работы нескольких этих камер. Странно что заземление свитчей увеличивает в разы частоту появления артефактов.

Или UTP кабель плохой? Частота завивки некорректная? Но производитель пишет типа флюком тестированный… SkyNet Premium UTP outdoor 4x2x0,51, медный, FLUKE TEST, кат.5e, однож., 100 м, box, черный CSP-UTP-4-CU-OUT/100

Проложить S/FTP вместо UDP? Но учитывая странный эффект от заземления свитчей – не понятно что будет при заземлении S/FTP.

Накупить ещё несколько POE-PD-свитчей, чтобы было не более 2 камер на каждом свитче? Но так ведь быть не должно!

Какие-то 1-портовые POE-PD свитчи-ретрансляторы? Но не нашёл подобного устройства (POE-инжекторы это наверно не решение проблемы т.к. не обеспечивают изоляции). Производители свитчей в своей рекламе предлагают использовать для ретрансляции длинных линий обычные 5-портовые POE-PD (громоздко, дорого, и не эффективный расход энергии), причём ставить их через каждые 100 метров (но у меня расстояния значительно меньше!). 

Не понятно насколько можно верить результатам длительного пингования (пакетами по 65кб) для оценки стабильности сети. 
Ночью длительное пингование камер показывает потери 20-25 пакетов из 4000.
Днём длительное пингование камер показывает потери 35-40 пакетов из 4000
Интересно что пингование с роутера до ближних камер (Cam2,Cam5) показывает ошибок больше чем до самой дальней камеры (Cam9).
Пинг с камеры (через SSH консоль) до роутера или до регистратора – аналогичный уровень потерь. Пинг между роутером и регистратором – потери единичные, из 4000 пингов иногда 1-2 пакета потеряны. Гипотеза о том что просто камеры не хотят или не могут отвечать на каждый пинг – в данном случае не подтверждается. 
Но, такие же потери пингов на камеры были и с заземлёнными корпусами свитчей, когда артефактов было значительно больше чем сейчас.
Очевидно что корреляции между процентом потерь пингов и интенсивностью артефактов нет.
Но как и чем тогда тестировать стабильность сети в течении длительного времени?

Итак, проверенные гипотезы:
1. Питание. Не подтвердилась по множеству причин – и запасы мощности (и по замерам и по расчётам) есть, и разные источники питания были (и с родными БП всего оборудования, и с низковольтным бесперебойником, и со сторонними БП).
2. Настройки камер. Перепробовано всё. Ну и проблема ведь только если камер несколько. Урезание битрейта до 5мбит тоже проверено.
3. Переключение сетевого интерфейса камер на 10Full, 10Half, 100Half – абсолютно не влияет на проблему. По индикаторам свитча и по скорости пинга – камеры реально переключаются. Так вообще порты камер работают все в 100Full.
4. Проблемы регистратора. Исключено полностью, при записи на сторонний NAS/Samba сервер – в записях дропы кадров в те же моменты времени когда у регистратора идут артефакты.
5. Проблема камер. Исключено, при записи на вставленную в камеры microSD артефактов/дропов нет, в те же самые моменты когда на NVR и NAS есть артефакты и дропы.
6. Заземление. При заземлении свитчей – артефактов стало значительно больше. Заземление убрал. Заземление было хорошее – около 15 м² железа на глубине 1-2м.
7. Ферритовые EMI-фильтры, поставил везде на UTP и на питание – хуже точно не стало, может даже немного лучше.
8. Подключение вместо камеры Hikvision DS-2CD2186G2© более простой камеры Hikvision DS-2CD1343G0© – на 2CD1343G0 никаких артефактов нет! Слабая сетевая часть у 2CD2186G2? Но менять их особо не на что – как бы это топовые камеры в линейке.
Прикрепления: 4448114.png (267.2 Kb)
 
  • Страница 1 из 1
  • 1
Поиск: